ARTICLE DETAIL

资讯详情

深耕网站视觉设计与运营推广的一线实战洞察。

银河麒麟系统解决FTP无法连接问题

银河麒麟系统解决FTP无法连接问题 在安装好ftpvsftpd之后终端运行ftp x.x.x.x(ip),输入用户名和密码后再ls出现refused等字眼则问题核心在于FTP的权限配置和被动模式设置。解决550 Permission denied权限不足这通常是因为启用了chroot_local_userYES但FTP用户的家目录又允许写入触发了 vsftpd 的安全机制。方法一推荐给家目录去除写权限创建子目录用于上传sudo chmod a-w /home/ronghe # 去除家目录的写权限 sudo mkdir -p /home/ronghe/upload # 创建一个专门用于上传的子目录 sudo chown ronghe:ronghe /home/ronghe/upload # 确保FTP用户对该子目录有所有权完成后使用ftp登录后cd upload即可上传文件。方法二在配置中允许chroot目录可写较便捷但安全性略低编辑/etc/vsftpd/vsftpd.conf添加或修改参数allow_writeable_chrootYES保存后执行sudo systemctl restart vsftpd重启服务即可。 解决Passive mode refused被动模式被拒绝这通常是因为配置文件里pasv_enable被设为了NO或者被动模式需要的端口没在防火墙放行。修改 vsftpd 配置编辑/etc/vsftpd/vsftpd.confpasv_enableYES pasv_min_port60000 pasv_max_port61000保存后重启服务sudo systemctl restart vsftpd。在防火墙放行端口如果系统开了防火墙firewalld需要放行这些端口sudo firewall-cmd --permanent --add-port60000-61000/tcp sudo firewall-cmd --reload如果用的是 iptables 或 ufw也请对应放行60000-61000/tcp端口。配置修改完成后记得用sudo systemctl restart vsftpd重启服务让设置生效。就个人使用情况而言pluma/etc/vsftpd/vsftpd.conf修改pasv_enableYES即可成功解决。
返回列表